• 热门专题

Android导入eclipse项目后 gradle版本引起的问题.md

作者:  发布日期:2015-05-18 23:02:50
Tag标签:版本  项目  问题  
  • android导入eclipse项目后,gradle版本引起的问题

        根据提示,在build.gradle 把
            dependencies {
                classpath 'com.android.tools.build:gradle:0.12.+'
            }
    
        修改为
            dependencies {
                classpath 'com.android.tools.build:gradle:1.2.3'
            }
    

    2.上面修改后会出现如下错误:Error:Unable to load class ‘org.codehaus.groovy.runtime.typehandling.ShortTypeHandling’.Possible causes for this unexpected error include:You are using JDK version ‘java version “1.7.0_71”’. Some versions of JDK 1.7 (e.g. 1.7.0_10) may cause class loading errors in Gradle.Please update to a newer version (e.g. 1.7.0_67).

    明明用的就是jdk1.7.0_71[比1.7.0_67还新] 却提示不对,问题起始不在jdk这而是 gradle-wrapper.properties distributionUrl=http://services.gradle.org/distributions/gradle-1.12-all.zip 用的是jdk1.7.0.10

        把    distributionUrl=http://services.gradle.org/distributions/gradle-1.12-all.zip
        修改为 distributionUrl=https://services.gradle.org/distributions/gradle-2.2.1-all.zip
    

    ok ,经过上面两步,从studio导入eclipse项目的正常使用。

    转载请注明 来自 http://blog.csdn.net/u011570979/article/details/45824073

About IT165 - 广告服务 - 隐私声明 - 版权申明 - 免责条款 - 网站地图 - 网友投稿 - 联系方式
本站内容来自于互联网,仅供用于网络技术学习,学习中请遵循相关法律法规